• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
v0.1.7 released
#1
The Aftermath Wizard has been updated to 0.1.7a.  If you created the zip before "Tues March 07, 2017" There was a few bugs that where found after released that needed to be addressed.  You can either go back to the AutoConfig form and recreate the wizard or download the 0.1.7Fix.zip and extract it into your wizard folder.

Getting Started:
If this is the first time you have tried the wizard i would recommend starting out with doing the text files first then moving on to the AutoConfig form that way they are already upload to a location.
If you need help with setting up the text files you can either visit the FAQS page or go to the wizard text folder in the repo folder
Credits.txt
Code:
Credits to all developers that some of the code came from
][NT3L][G3NC][ :  For APK Install code and Force Close Fix
TVAddons.ag    :  Scrollbar Images and Source for dependencies
Kodi Team      :  Kodi Log Uploader(Added support for forks and email log url)
Sean Poyser    :  YouTube module
EchoCoder      :  Help with Addons27.db
Surfacingx     :  Creator of the Wizard

Special Thanks to the NaN Team for giving me a home when i was first starting out coding python and helping me out along the way.
This wizard wouldn't be no where near as good as it is today if it wasnt for them.
WhufcLee, OpenEleq, Midraal : Various coding help  
Barroni        :  Artwork for Advanced Settings Auto Configurator

Changelog.txt
 
Code:
v0.1.7a
-Mod   tweaked code to prevent 2nd startup
-Fixed bug where started with second char in notifications
-Fixed bug when only 1 build is avaliable and shows kodi version and save data twice
-Fixed bug in backup build

v0.1.7
-Added First Run Save Data Window
-Added New Window for Viewing Log Files
-Added Custom window for TextBoxes
-Added Install build without force close
-Added Install method to Settings (Always Ask, Reload Profile, Force Close)
-Added 'Remove Advanced Settings' in menu's
-Added Keep Repo's, Keep Super Favorities and WhiteList
-Added Import and Export Save Data/WhiteList
-Added PVR plugin in whitelist will re-enable on startup after install
-Added Video Preview for builds
-Added Test Builds only appear in developer mode(any build with the word test in the name)
-Added Sections for APK, Addon Installer, Advanced Settings, and Youtube Videos
-Added Adult attribute to Themes List
-Added 3rd Party Wizard support
-Added More support for Kodi 17 and Addons27.db
-Added Exception for 'meta_cache' and 'archive_cache' in clear cache(watched items)
-Added Ability to change the icon and fanart for the contact window
-Added Scraper for SPMC and Kodi Apks.
-Added Convert text to 0.1.7 text files
-Added Fix for meta and forks when installed from build
-Added Convert to Special on Backup guiFix and Themes
-Added Reinstall addon to addoninstaller
-Added Kodi 18 to build menu
-Added Addon support to theme backups
-Mod   Redid how the remove addons worked.
-Mod   Working url check now tries 3 times before returning a bad url
-Mod   Clear packages on startup reduced to 3 minutes(down from 5)
-Mod   If skin is set to 50 default, it uses 55 on 'skin.estuary'
-Mod   Converted all custom windows except advanced settings to .xml files
-Mod   Convert to special on guifix and theme
-Mod   Tweaks to addon installer
-Fixed Bugs in downloader.py and save data.
-Fixed Bug in SmoothStreams Login Data
-Fixed Bug in Trakt, Debrid, Login - clear addon data
-Fixed Bug in removing old thumbnails
-Fixed Bug in Kodi 17 Builds showing Kodi 16 count
-Fixed Bug in Kodi 17 causing startup to run twice
-Fixed Bugs in Backup/Restore when using external and network locations
-Rem   Header and message font size in uservar.py
[Image: nansig_surfacingx.png]
  Reply
#2
Hello , 

Great release working really well and new features look good. Small issue though wonder if you know how to resolve. On first install it loads up notification window and when you press dismiss, it loads the next part then press "build menu" it then loads build menu,  but it starts that cycle again also  e.g. Notifications > dismiss > menu > build menu. Just seems like it's very starting up twice ? Thanks for any replies.
  Reply
#3
Let me guess ur kodi 17.1? I messaged kodi twice and never received a reply from them. But I found maybe 2-3 bugs that I need to fix. I am down to the last one and hopefully can re-release the zip tonight. I will create a fix zip that u can just extract into ur wizard folder then just rezip it.

Sent from my SM-N920V using Tapatalk
[Image: nansig_surfacingx.png]
  Reply
#4
Thanks for fast reply + yeah sorry forgot to put Kodi version. + thanks!
  Reply
#5
Not a problem. I gotta make sure the startup is working correctly then I'll post a zip file. Just extract that into ur wizard folder and it should fix the bugs unless u want to redo the AutoConfig, completely up to you. Give me 5 or 10 minutes and ill reply.

Sent from my SM-N920V using Tapatalk
[Image: nansig_surfacingx.png]
  Reply
#6
No rush mate, thanks for your time , don't worry about making a zip I will re-do AutoConfig save you some hassle, was gonna ask on twitter but see you opened forum, much better because everyone can see the issues. Instead of getting asked 100+ times same issue.


Sent from my iPhone using Tapatalk
  Reply
#7
Well it seems like 51 wizards have been created since it was released so i created a zip anyways.. The issue with wizard startup seems to be addressed but if it isnt then please let me know.

Extract this zip into your wizard folder, it will overwrite the default.py, changelog.txt, startup.py, wizard.py and APK.xml
http://aftermathwizard.net/repo/zips/0.1.7fix.zip

Code:
v0.1.7a
-Mod   tweaked code to prevent 2nd startup
-Fixed bug where started with second char in notifications
-Fixed bug when only 1 build is avaliable and shows kodi version and save data twice
-Fixed bug in backup build
[Image: nansig_surfacingx.png]
  Reply
#8
Just confirming your zip fixes the issues perfectly ! Thanks !


Sent from my iPhone using Tapatalk
  Reply
#9
(03-07-2017, 03:55 PM)Grizzlar Wrote: Just confirming your zip fixes the issues perfectly ! Thanks !


Sent from my iPhone using Tapatalk
No problem. If u need any more help or suggestions for the next update let me know.

Sent from my SM-N920V using Tapatalk
[Image: nansig_surfacingx.png]
  Reply
#10
still having issue when updating from .1.6 to .1.7 gives an error any ideas. oh im using the autoconfig from website and just replacing zip
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)